DNS resolution issues
Incident Report for Section
Postmortem

A DNS resolution issue with the Section platform resulted in customer web applications being inaccessible to end-users. Section runs redundant DNS providers to improve total availability. Section’s platform received internal errors that corrupted platform decisions about DNS routing when communicating with the DNS provider’s API. As DNS propagated, customer web applications began to become inaccessible by end-users. Section engineering worked to correct the faulty records by successfully migrating to Section’s secondary DNS provider. The duration of the incident would have varied by customer depending on the timing of complete DNS propagation.

An internal fix has been rolled out to production.

Posted Jun 02, 2021 - 19:29 UTC

Resolved
Section Engineering has confirmed this issue is now completely resolved.
Posted Jun 01, 2021 - 20:41 UTC
Monitoring
A fix has been implemented to remediate DNS resolution issues and we are monitoring the changes.
Posted Jun 01, 2021 - 19:41 UTC
Identified
We've identified the issue with the DNS resolution and our engineers are working on a fix.
Posted Jun 01, 2021 - 19:35 UTC
Investigating
Section engineering is investigating DNS issues.
Posted Jun 01, 2021 - 19:16 UTC
This incident affected: DNS.